Can't locate version.pm

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't locate version.pm

gdipankar
I am installing a fresh installation of Bugzilla 4.4.2.
I get the following error when running ./checksetup.pl:
Can't locate version.pm in @INC (@INC contains: . lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at Bugzilla/Install/Requirements.pm line 17.

What may be the reason ?
Reply | Threaded
Open this post in threaded view
|

Re: Can't locate version.pm

Thorsten Schöning
Guten Tag gdipankar,
am Freitag, 4. April 2014 um 12:40 schrieben Sie:

> I get the following error when running ./checksetup.pl:
> *Can't locate version.pm in @INC

Search for the file and decide afterwards, because it should be
present in a default Perl installation, but some packages are
providing same named files as well. So you need to first make sure
which one is missing and such.

find / -name version.pm

Mit freundlichen Grüßen,

Thorsten Schöning

--
Thorsten Schöning       E-Mail:[hidden email]
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

RE: Can't locate version.pm

Alonso, Daniel
You can use the 'Agent Ransack' app it's very useful to find files or text within.
Good luck!

Daniel Luevano Alonso | Tool Support Engineer
Phone |  214 5673309
[hidden email]


-----Original Message-----
From: support-bugzilla [mailto:support-bugzilla-bounces+daniel.alonso=[hidden email]] On Behalf Of Thorsten Schöning
Sent: Friday, April 04, 2014 6:00 AM
To: [hidden email]
Subject: Re: Can't locate version.pm

Guten Tag gdipankar,
am Freitag, 4. April 2014 um 12:40 schrieben Sie:

> I get the following error when running ./checksetup.pl:
> *Can't locate version.pm in @INC

Search for the file and decide afterwards, because it should be present in a default Perl installation, but some packages are providing same named files as well. So you need to first make sure which one is missing and such.

find / -name version.pm

Mit freundlichen Grüßen,

Thorsten Schöning

--
Thorsten Schöning       E-Mail:[hidden email]
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

RE: Can't locate version.pm

gdipankar
I am able to find the solution.
The version module for PERL was not installed. So I did :
# perl –MCPAN –e shell
     > install version

Then it started working !!! :-)

Thank you very much for your help.