Building in x86_64 openSUSE 11.1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Building in x86_64 openSUSE 11.1

AndyG-2
For some reason, building Mozilla in 64-bit SUSE is a problem. A file
called automationutils.py is not created and a couple of autoconf.mk
files sit in the way of compiling successfully. I'm not sure what the
source of the problem is, but unless you have a workaround, you can't
build.

I posted a detailed workaround on www.xcept.com/tbirdcompile.html.

I hope it helps some folks, and I hope that somebody will be able to
figure out what the root cause is.

Have fun,

Andy
_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds
Reply | Threaded
Open this post in threaded view
|

Re: Building in x86_64 openSUSE 11.1

Frank Wein
AndyG wrote:

> For some reason, building Mozilla in 64-bit SUSE is a problem. A file
> called automationutils.py is not created and a couple of autoconf.mk
> files sit in the way of compiling successfully. I'm not sure what the
> source of the problem is, but unless you have a workaround, you can't
> build.
>
> I posted a detailed workaround on www.xcept.com/tbirdcompile.html.
>
> I hope it helps some folks, and I hope that somebody will be able to
> figure out what the root cause is.
>
> Have fun,
>
> Andy

Why do you run ./configure directly in your source folder when using a
objdir? AFAIK this is wrong, just run make -f client.mk build, this will
also run configure (in your objdir).

Frank

_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds