Bugzilla upgrade

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Bugzilla upgrade

Jack Sparrow
Can anyone please tell me how to upgrade bugzilla from 3.6.3 to 4.4 on windows server 2003

I tried below steps but facing problem.

1) Installed 3.6.3 version using exe file.
2) Created test bugs.
3) Downloaded tar file and untared file.
4) Renamed bugzilla file to the latest one ie c:/bugzilla 4.4 to bugzilla and earlier version to backup.
5) Now when i run checksetup.pl file, it is asking for Email::MIME perl module.
6) Installed using command ppm install Email-MIME.
7) when I run checksetup.pl file again, its asking me to install Email::MIME perl module.

Please help me out where i'm missing?
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla upgrade

Thorsten Schöning
Guten Tag Jack Sparrow,
am Mittwoch, 21. August 2013 um 08:36 schrieben Sie:

> 5) Now when i run checksetup.pl file, it is asking for Email::MIME perl
> module.
> 6) Installed using command ppm install Email-MIME.
> 7) when I run checksetup.pl file again, its asking me to install Email::MIME
> perl module.

Which versions of the package are installed and required? They may be
a difference because the old installer provided an own, now maybe
outdated Perl distribution. It may even be that you have more than one
Perl installation available, on globally installed, one locally from
the installer.

From my point of view this is your chance to leave the old installer
behind and start from scratch. You already downloaded Bugzilla, MySQL,
httpd and Perl just need to get downloaded and executed, too. Copy
your already present httpd configuration and you have installed
Bugzilla following the official docs. Which may save you problems,
there doesn't seem to be that many people using the installer anymore,
it's outdated and unsupported.

http://www.bugzilla.org/docs/4.4/en/html/installing-bugzilla.html
https://wiki.mozilla.org/Bugzilla:Win32Install

Mit freundlichen Grüßen,

Thorsten Schöning

--
Thorsten Schöning       E-Mail:[hidden email]
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla upgrade

Jack Sparrow
Thank you for the quick reply. Its working.

Now how to upgrade mysql data from 3.6.3 to 4.4. I see that we have new 4 tables created 4.4 version.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla upgrade

Thorsten Schöning
Guten Tag Jack Sparrow,
am Mittwoch, 21. August 2013 um 12:55 schrieben Sie:

> Now how to upgrade mysql data from 3.6.3 to 4.4. I see that we have new 4
> tables created 4.4 version.

checksetup.pl does all you need, there no need to manually upgrade
anything.

If you followed my suggestion and did a fresh new install, just follow
the docs to dump and load your existing database.

https://wiki.mozilla.org/Bugzilla:Move_Installation

Mit freundlichen Grüßen,

Thorsten Schöning

--
Thorsten Schöning       E-Mail:[hidden email]
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.