Bugzilla email configuration

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bugzilla email configuration

helenaki83
Hello,

I have installed Bugzilla (version 4.2.16) on Linux Server
release 6.4 (Santiago) and the issue I am facing is that
everytime I complete an action that involves the generation
of an email
(for example when I input a new user request and enter an
email for validation), I am getting an error similar to the
one below:

Bugzilla has suffered an internal error. Please save this
page and send it to [hidden email] with details of what you
were doing at the time this message appeared.

URL:
http://10.1.148.3/bugzilla-4.2.16/createaccount.cgi?login=yyy@mydomain&token=1541596479-7734b9e349dc08fee308eeed6d56c6f8

There was an error sending mail from '@10.1.148.3' to '':
Can't call method "address" on an undefined value
at /usr/local/share/perl5/Email/Send/SMTP.pm line 29.

Traceback:
 at Bugzilla/Mailer.pm line 196
        Bugzilla::Mailer::MessageToMTA(...) called at
Bugzilla/Token.pm line 91
        Bugzilla::Token::issue_new_user_account_token(...)
called at Bugzilla/User.pm line 2013

Bugzilla::User::check_and_send_account_creation_confirmation
(...) called
at /gl/lungl/www/html/bugzilla-4.2.16/createaccount.cgi line
55



I have configured my email parameters as:

mail_delivery_method    -> SMTP
mailfrom                                -> bugzilla-daemon  (I have
also tried my other valid emails)
use_mailer_queue                -> off
smtpserver                              -> 10.0.0.4
smtp_username                   -> I have left this empty
smtp_password                   -> I have left this empty as well
smtp_debug                              -> on

also in 'Required settings' options I have configured the
urlbase as follows:

http://10.1.148.3/bugzilla-4.2.16/

I would appreciate any insight on the issue.

Many thanks.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla email configuration

helenaki83
On Thursday, November 8, 2018 at 9:58:08 AM UTC+2, [hidden email] wrote:

> Hello,
>
> I have installed Bugzilla (version 4.2.16) on Linux Server
> release 6.4 (Santiago) and the issue I am facing is that
> everytime I complete an action that involves the generation
> of an email
> (for example when I input a new user request and enter an
> email for validation), I am getting an error similar to the
> one below:
>
> Bugzilla has suffered an internal error. Please save this
> page and send it to [hidden email] with details of what you
> were doing at the time this message appeared.
>
> URL:
> http://10.1.148.3/bugzilla-4.2.16/createaccount.cgi?login=yyy@mydomain&token=1541596479-7734b9e349dc08fee308eeed6d56c6f8
>
> There was an error sending mail from '@10.1.148.3' to '':
> Can't call method "address" on an undefined value
> at /usr/local/share/perl5/Email/Send/SMTP.pm line 29.
>
> Traceback:
>  at Bugzilla/Mailer.pm line 196
>         Bugzilla::Mailer::MessageToMTA(...) called at
> Bugzilla/Token.pm line 91
>         Bugzilla::Token::issue_new_user_account_token(...)
> called at Bugzilla/User.pm line 2013
>
> Bugzilla::User::check_and_send_account_creation_confirmation
> (...) called
> at /gl/lungl/www/html/bugzilla-4.2.16/createaccount.cgi line
> 55
>
>
>
> I have configured my email parameters as:
>
> mail_delivery_method    -> SMTP
> mailfrom                                -> bugzilla-daemon  (I have
> also tried my other valid emails)
> use_mailer_queue                -> off
> smtpserver                              -> 10.0.0.4
> smtp_username                   -> I have left this empty
> smtp_password                   -> I have left this empty as well
> smtp_debug                              -> on
>
> also in 'Required settings' options I have configured the
> urlbase as follows:
>
> http://10.1.148.3/bugzilla-4.2.16/
>
> I would appreciate any insight on the issue.
>
> Many thanks.

We want the testopia plugin. For testopia2.5 the highest compatible release we can have is 4.4.13?
Should we give it a try?
For the "from" part we tried valid e-mails but still have the same issue.


Thank you

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.