Bugzilla 2.22.1 - Template::Plugin::GD::Image

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Bugzilla 2.22.1 - Template::Plugin::GD::Image

Michael Bellomo
I just upgraded a test copy of our bugzilla installation to 2.22.1 this
morning.  When I run checksetup, I see it searching for a new module
that it didn't used to look for:

Checking for Template::Plugin::GD::Image (any)      not found

Anyone know which package Fedora 5 thinks that's in?  I've looked around
a bit, but am having no luck.  Thanks in advance.

    -Michael

ps - yes, I know I could use cpan to get it, but would prefer to use yum
if possible.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla 2.22.1 - Template::Plugin::GD::Image

Max Kanat-Alexander
On Mon, 2006-10-16 at 11:01 -0400, Michael Bellomo wrote:
> Anyone know which package Fedora 5 thinks that's in?

        perl-Template-GD

        -Max
--
http://www.everythingsolved.com/
Everything Solved: Competent, Friendly Bugzilla and Linux Services

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla 2.22.1 - Template::Plugin::GD::Image

Michael Bellomo

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla 2.22.1 - Template::Plugin::GD::Image

Max Kanat-Alexander
On Mon, 2006-10-16 at 23:18 -0400, Michael Bellomo wrote:
> Any other suggestions Max?  No luck on that one.  Here's some yum
> output:
> [snip]

        Hrm. What version of Template-Toolkit is Fedora Extras shipping? 2.14?
Because with that, you should automatically have Template-GD and you
shouldn't need to install it separately.

        If they ship Template-Toolkit 2.15, you do need Template-GD separately.
You can install cpan2rpm and do "cpan2rpm Template-GD" as root to create
a Template-GD RPM, if Extras doesn't have one yet.

        Extras actually ships Bugzilla, so they'll add all the new requirements
soon if they haven't yet.

        -Max
--
http://www.everythingsolved.com/
Everything Solved: Competent, Friendly Bugzilla and Linux Services

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla 2.22.1 - Template::Plugin::GD::Image

Michael Bellomo

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla 2.22.1 - Template::Plugin::GD::Image

Tim Thome-2
In reply to this post by Michael Bellomo
Max Kanat-Alexander wrote:

> On Mon, 2006-10-16 at 23:18 -0400, Michael Bellomo wrote:
>> Any other suggestions Max?  No luck on that one.  Here's some yum
>> output:
>> [snip]
>
> Hrm. What version of Template-Toolkit is Fedora Extras shipping? 2.14?
> Because with that, you should automatically have Template-GD and you
> shouldn't need to install it separately.
>
> If they ship Template-Toolkit 2.15, you do need Template-GD separately.
> You can install cpan2rpm and do "cpan2rpm Template-GD" as root to create
> a Template-GD RPM, if Extras doesn't have one yet.
>
> Extras actually ships Bugzilla, so they'll add all the new requirements
> soon if they haven't yet.
>
> -Max

shellprompt> perl -MCPAN -e 'install"Template::Plugin::GD::Image"'

Should work just fine with Fedora Core 4 and Fedora Core 5

worked for me... after banging my head for a couple of hours... (prod
box had template toolkit 2.14 which included in the plugin, dev box had
2.15 of the toolkit where the dist broke out the plugins)

(FWIW minor bitch - what I dislike is running on the bugzilla cvs tip,
checksetup.pl no longer specs out exactly what perl modules are present,
and the email modules are not installing correctly, no time for debug at
the present, but they're optional, for now...)

Tim
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla 2.22.1 - Template::Plugin::GD::Image

Michael Bellomo
Tim Thome wrote:
> shellprompt> perl -MCPAN -e 'install"Template::Plugin::GD::Image"'
>
> Should work just fine with Fedora Core 4 and Fedora Core 5
I personally have no problem with that.  The problem is that our IT
department would rather see it installed as a yum installed package from
Fedora.  This way they won't have to update it separately, yum's update
will just get it.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla 2.22.1 - Template::Plugin::GD::Image

Tim Thome-2
In reply to this post by Tim Thome-2
Michael Bellomo wrote:
> Tim Thome wrote:
>> shellprompt> perl -MCPAN -e 'install"Template::Plugin::GD::Image"'
>>
>> Should work just fine with Fedora Core 4 and Fedora Core 5
> I personally have no problem with that.  The problem is that our IT
> department would rather see it installed as a yum installed package from
> Fedora.  This way they won't have to update it separately, yum's update
> will just get it.

The plugin for GD::Image was broken out of the Template Toolkit in 2.15,
can you regress the toolkit back to 2.14, and then the plugin might be
installed?

Tim
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla 2.22.1 - Template::Plugin::GD::Image

Max Kanat-Alexander
In reply to this post by Tim Thome-2
On Thu, 2006-10-19 at 00:55 -0700, Tim Thome wrote:
> (FWIW minor bitch - what I dislike is running on the bugzilla cvs tip,
> checksetup.pl no longer specs out exactly what perl modules are present,

        Um, what? Yes it does.

        -Max
--
http://www.everythingsolved.com/
Competent, Friendly Bugzilla Services. And Everything Else, too.

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla 2.22.1 - Template::Plugin::GD::Image

Tim Thome-2
In reply to this post by Tim Thome-2
Max Kanat-Alexander wrote:
> On Thu, 2006-10-19 at 00:55 -0700, Tim Thome wrote:
>> (FWIW minor bitch - what I dislike is running on the bugzilla cvs tip,
>> checksetup.pl no longer specs out exactly what perl modules are present,
>
> Um, what? Yes it does.
>
> -Max

Max,

FWIW - there are few running on the tip (I don't for prod, but for dev),
having MIN vs. Installed is very helpful for debug. I've been burned in
the past with perl breaking things...

This change is not helpful, IMHO...

Tim
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla 2.22.1 - Template::Plugin::GD::Image

Max Kanat-Alexander
On Fri, 2006-10-20 at 01:50 -0700, Tim Thome wrote:
> having MIN vs. Installed is very helpful for debug.

        Min vs. Installed is still there. Look at all the output, not just the
bottom.

        -Max
--
http://www.everythingsolved.com/
Competent, Friendly Bugzilla Services. And Everything Else, too.

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Bugzilla 2.22.1 - Template::Plugin::GD::Image

Tim Thome-2
In reply to this post by Tim Thome-2
Max Kanat-Alexander wrote:
> On Fri, 2006-10-20 at 01:50 -0700, Tim Thome wrote:
>> having MIN vs. Installed is very helpful for debug.
>
> Min vs. Installed is still there. Look at all the output, not just the
> bottom.
>
> -Max

Max,

It's a fairly minor nit to pick anyways.

Like what you and the team are doing, 2.23.3+ is looking very good...

Tim
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.