3rd instance of bugzilla....

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

3rd instance of bugzilla....

bugzillanewbie2005
hello all,

I have recently completed a bugzilla server move. The details...
2 instances of bugzilla 2.17 customized moved from one windows 2000,
IIS, mysql, perl server to another server with the same setup.
Everything is working fine.

the problem:

I've been asked to create a brand new bugzilla instance for another
business unit on the same server. I've created the mysql database and
perl is already installed. How do I create a blank/new instance of
bugzilla 2.17 customized version?

thanks

_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: 3rd instance of bugzilla....

David T. Ashley-2
> I've been asked to create a brand new bugzilla instance for another
> business unit on the same server. I've created the mysql database and
> perl is already installed. How do I create a blank/new instance of
> bugzilla 2.17 customized version?

Bugzilla's behavior and data are contained in exactly two places:

a)The hierarchical web content (the Perl scripts, templates, etc.).

b)The MySQL database.

Just do this:

a)Recursively copy the Bugzilla web content you like to a new location.

b)Set up Apache to point to the new location as desired.

c)Create a new database in MySQL.

d)Change the localconfig file in the new location to have the database
name and password.

e)Run the checksetup.pl program in the new location.

f)Make sure the whining cron is set up.

That is all.

We have six Bugzilla databases.  It gets easier each time to clone them.

Dave.

_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: 3rd instance of bugzilla....

bugzillanewbie2005
In reply to this post by bugzillanewbie2005
thanks for your reply.

ive followed your instructions but am receiving the following message:

Bugzilla has suffered an internal error. Please save this page and
submit it as a bug in the  Bugzilla database on the Bugzilla product
with details of what you were doing at the time this message appeared.

URL: http://newbugs/

Template->process() failed twice.
First error: undef error - No value for param orgname at
Bugzilla/Config.pm line 135.
Second error: undef error - No value for param orgname at
Bugzilla/Config.pm line 135.

thanks

_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools