10.0.4 printting

classic Classic list List threaded Threaded
76 messages Options
1234
Reply | Threaded
Open this post in threaded view
|

10.0.4 printting

Barry Landy
Both the preview and the releeas of 10.0.4

printing to a CUPS USB connected printer works fine; printing to a LPT1
connected printer (HP5Llaserjet in case it matters) causes FF10 to end
with a beep.

--
Barry Landy                        Email: Remove nospam in from address
192, Gilbert Road, Cambridge CB4 3PB









_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Dave Yeo-3
Barry Landy wrote:
> Both the preview and the releeas of 10.0.4
>
> printing to a CUPS USB connected printer works fine; printing to a LPT1
> connected printer (HP5Llaserjet in case it matters) causes FF10 to end
> with a beep.
>

Can you look in your Firefox program directory and post the trp file to
[hidden email]? preferably as a text attachment. As far as I know
it shouldn't matter how the printer is connected but I'm not the expert.
Perhaps Rich will become involved again and the trp file may help
diagnose the problem or something will stand out in it.
Dave
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Dave Yeo-3
In reply to this post by Barry Landy
Barry Landy wrote:
> Both the preview and the releeas of 10.0.4
>
> printing to a CUPS USB connected printer works fine; printing to a LPT1
> connected printer (HP5Llaserjet in case it matters) causes FF10 to end
> with a beep.

Also has anyone else had experience printing to a printer connected to
anything besides USB?
Dave
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Steve Wendt
On 5/8/2012 7:15 PM, Dave Yeo wrote:

>> printing to a CUPS USB connected printer works fine; printing to a LPT1
>> connected printer (HP5Llaserjet in case it matters) causes FF10 to end
>> with a beep.
>
> Also has anyone else had experience printing to a printer connected to
> anything besides USB?

I haven't tried lately, but my HP Laserjet is connected to LPT1.
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Steve Wendt
On 05/08/12 07:57 pm, Steve Wendt wrote:

> I haven't tried lately, but my HP Laserjet is connected to LPT1.

Works fine, using the PostScript driver.  I have both of these values
set to true:  print.os2.postscript.use_builtin and ...use_ibmnull.

 From what I recall of earlier testing, other values worked, but
produced grainy results.

I do seem to recall at least one other user having problems with
printing to an HP Laserjet, but I don't know if there was ever a resolution.

FWIW, mine is a 4250n, using the 4/4M Plus PS 300 version 30.827
PostScript driver.
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Lewis Rosenthal-2
In reply to this post by Dave Yeo-3
On 05/08/12 10:15 pm, Dave Yeo thus wrote :

> Barry Landy wrote:
>> Both the preview and the releeas of 10.0.4
>>
>> printing to a CUPS USB connected printer works fine; printing to a LPT1
>> connected printer (HP5Llaserjet in case it matters) causes FF10 to end
>> with a beep.
>
> Also has anyone else had experience printing to a printer connected to
> anything besides USB?
> Dave

I print to network-attached printers, either directly to the IP or via
captured parallel port to a NetWare queue. (Note that a NetWare-captured
port is not the same as a redirected port in the spooler, though the end
result is, obviously, the same.)

I just tested here under SM & FF (to an HP Color LaserJet 3800, using
the native driver), and no crashes printing to a captured port. I don't
have a parallel (or serial!) printer around at the moment to test via a
cable.

Barry, is your spooler enabled or disabled? I suppose that it might be
possible to overload the print stream with the spooler disabled going
over a parallel port, depending upon the amount of data being sent. I'm
not sure of the buffering available in the application, in that case.

--
Lewis
-------------------------------------------------------------
Lewis G Rosenthal, CNA, CLP, CLE, CWTS
Rosenthal & Rosenthal, LLC                www.2rosenthals.com
Need a managed Wi-Fi hotspot?                www.hautspot.com
visit my IT blog                www.2rosenthals.net/wordpress
-------------------------------------------------------------
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Barry Landy
In reply to this post by Dave Yeo-3
On Tue, 8 May 2012, Dave Yeo wrote:

:>Barry Landy wrote:
:>> Both the preview and the releeas of 10.0.4
:>>
:>> printing to a CUPS USB connected printer works fine; printing to a LPT1
:>> connected printer (HP5Llaserjet in case it matters) causes FF10 to end
:>> with a beep.
:>>
:>
:>Can you look in your Firefox program directory and post the trp file to
:>[hidden email]? preferably as a text attachment. As far as I know it
:>shouldn't matter how the printer is connected but I'm not the expert. Perhaps
:>Rich will become involved again and the trp file may help diagnose the problem
:>or something will stand out in it.
:>Dave
:>

I have attached the .trp file which indicates an C0000005 trap.

--
Barry Landy                        Email: Remove nospam in from address
192, Gilbert Road, Cambridge CB4 3PB









_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Barry Landy
In reply to this post by Steve Wendt
On Tue, 8 May 2012, Steve Wendt wrote:

:>On 05/08/12 07:57 pm, Steve Wendt wrote:
:>
:>> I haven't tried lately, but my HP Laserjet is connected to LPT1.
:>
:>Works fine, using the PostScript driver.  I have both of these values set to
:>true:  print.os2.postscript.use_builtin and ...use_ibmnull.
:>
:>From what I recall of earlier testing, other values worked, but produced
:>grainy results.
:>
:>I do seem to recall at least one other user having problems with printing to
:>an HP Laserjet, but I don't know if there was ever a resolution.
:>
:>FWIW, mine is a 4250n, using the 4/4M Plus PS 300 version 30.827 PostScript
:>driver.
:>

I should have said that I have not had preblems printing with earlier
releases.

I use the HP LASERJET 5L driver as AFAIK spooling is on.

--
Barry Landy                        Email: Remove nospam in from address
192, Gilbert Road, Cambridge CB4 3PB









_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Barry Landy
In reply to this post by Barry Landy
On Tue, 8 May 2012, Barry Landy wrote:

:>Both the preview and the releeas of 10.0.4
:>
:>printing to a CUPS USB connected printer works fine; printing to a LPT1
:>connected printer (HP5Llaserjet in case it matters) causes FF10 to end with a
:>beep.
:>
:>

extra points:
1) it happens on two different computer with very different specs
2) Firefox 10.0 does NOT show this effect (printing to the HPL5 via LPT1
works fine).

--
Barry Landy                        Email: Remove nospam in from address
192, Gilbert Road, Cambridge CB4 3PB









_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Dave Saville-6
In reply to this post by Dave Yeo-3
On Wed, 9 May 2012 02:15:03 UTC, Dave Yeo <[hidden email]>
wrote:

> Barry Landy wrote:
> > Both the preview and the releeas of 10.0.4
> >
> > printing to a CUPS USB connected printer works fine; printing to a LPT1
> > connected printer (HP5Llaserjet in case it matters) causes FF10 to end
> > with a beep.
>
> Also has anyone else had experience printing to a printer connected to
> anything besides USB?
> Dave

Printing to my HP Laserjet 4L which is network attached (slpr) works
fine.

--
Regards
Dave Saville
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

David McKenna
In reply to this post by Dave Yeo-3
On Tue, 08 May 2012 19:15:03 -0700, Dave Yeo wrote:

>Barry Landy wrote:
>> Both the preview and the releeas of 10.0.4
>>
>> printing to a CUPS USB connected printer works fine; printing to a LPT1
>> connected printer (HP5Llaserjet in case it matters) causes FF10 to end
>> with a beep.
>
>Also has anyone else had experience printing to a printer connected to
>anything besides USB?

  Works fine (both your latest SeaMonkey and FF) printing over the network to
a CUPS server (which itself sends the job over the network).

Dave McKenna



_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Barbara-46
In reply to this post by Dave Yeo-3
On Wed, 9 May 2012 02:15:03 UTC, Dave Yeo <[hidden email]>
wrote:

> Barry Landy wrote:
> > Both the preview and the releeas of 10.0.4
> >
> > printing to a CUPS USB connected printer works fine; printing to a LPT1
> > connected printer (HP5Llaserjet in case it matters) causes FF10 to end
> > with a beep.
>
> Also has anyone else had experience printing to a printer connected to
> anything besides USB?
> Dave

Parallel, LPT1 to Brother B/W Laser and HP2550L Color Laserjet work
fine.

--
Barbara
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Dave Yeo-3
In reply to this post by Barry Landy
Barry Landy wrote:

> On Tue, 8 May 2012, Dave Yeo wrote:
>
> :>Barry Landy wrote:
> :>>  Both the preview and the releeas of 10.0.4
> :>>
> :>>  printing to a CUPS USB connected printer works fine; printing to a LPT1
> :>>  connected printer (HP5Llaserjet in case it matters) causes FF10 to end
> :>>  with a beep.
> :>>
> :>
> :>Can you look in your Firefox program directory and post the trp file to
> :>[hidden email]? preferably as a text attachment. As far as I know it
> :>shouldn't matter how the printer is connected but I'm not the expert. Perhaps
> :>Rich will become involved again and the trp file may help diagnose the problem
> :>or something will stand out in it.
> :>Dave
> :>
>
> I have attached the .trp file which indicates an C0000005 trap.
>

Try disabling the Innotek Font engine.
Dave
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Dave Yeo-3
In reply to this post by Barry Landy
Barry Landy wrote:

> On Tue, 8 May 2012, Barry Landy wrote:
>
> :>Both the preview and the releeas of 10.0.4
> :>
> :>printing to a CUPS USB connected printer works fine; printing to a LPT1
> :>connected printer (HP5Llaserjet in case it matters) causes FF10 to end with a
> :>beep.
> :>
> :>
>
> extra points:
> 1) it happens on two different computer with very different specs
> 2) Firefox 10.0 does NOT show this effect (printing to the HPL5 via LPT1
> works fine).
>

What about 10.02?
Dave
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Barry Landy
In reply to this post by Dave Yeo-3
On Wed, 9 May 2012, Dave Yeo wrote:

:>Barry Landy wrote:
:>> On Tue, 8 May 2012, Dave Yeo wrote:
:>>
:>> :>Barry Landy wrote:
:>> :>>  Both the preview and the releeas of 10.0.4
:>> :>>
:>> :>>  printing to a CUPS USB connected printer works fine; printing to a LPT1
:>> :>>  connected printer (HP5Llaserjet in case it matters) causes FF10 to end
:>> :>>  with a beep.
:>> :>>
:>> :>
:>> :>Can you look in your Firefox program directory and post the trp file to
:>> :>[hidden email]? preferably as a text attachment. As far as I know it
:>> :>shouldn't matter how the printer is connected but I'm not the expert.
:>> Perhaps
:>> :>Rich will become involved again and the trp file may help diagnose the
:>> problem
:>> :>or something will stand out in it.
:>> :>Dave
:>> :>
:>>
:>> I have attached the .trp file which indicates an C0000005 trap.
:>>
:>
:>Try disabling the Innotek Font engine.
:>Dave
:>

OK. I found MOZINST which includes fechg.exe which enables switching
on.off the font engine and that does cure the exception.

--
Barry Landy                        Email: Remove nospam in from address
192, Gilbert Road, Cambridge CB4 3PB









_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Barry Landy
In reply to this post by Dave Yeo-3
On Wed, 9 May 2012, Dave Yeo wrote:

:>Barry Landy wrote:
:>> On Tue, 8 May 2012, Barry Landy wrote:
:>>
:>> :>Both the preview and the releeas of 10.0.4
:>> :>
:>> :>printing to a CUPS USB connected printer works fine; printing to a LPT1
:>> :>connected printer (HP5Llaserjet in case it matters) causes FF10 to end
:>> with a
:>> :>beep.
:>> :>
:>> :>
:>>
:>> extra points:
:>> 1) it happens on two different computer with very different specs
:>> 2) Firefox 10.0 does NOT show this effect (printing to the HPL5 via LPT1
:>> works fine).
:>>
:>
:>What about 10.02?
:>Dave
:>

Same as 10.0 ( no exception)

--
Barry Landy                        Email: Remove nospam in from address
192, Gilbert Road, Cambridge CB4 3PB









_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Barry Landy
On Wed, 9 May 2012, Barry Landy wrote:

:>On Wed, 9 May 2012, Dave Yeo wrote:
:>
:>:>Barry Landy wrote:
:>:>> On Tue, 8 May 2012, Barry Landy wrote:
:>:>>
:>:>> :>Both the preview and the releeas of 10.0.4
:>:>> :>
:>:>> :>printing to a CUPS USB connected printer works fine; printing to a LPT1
:>:>> :>connected printer (HP5Llaserjet in case it matters) causes FF10 to end
:>:>> with a
:>:>> :>beep.
:>:>> :>
:>:>> :>
:>:>>
:>:>> extra points:
:>:>> 1) it happens on two different computer with very different specs
:>:>> 2) Firefox 10.0 does NOT show this effect (printing to the HPL5 via LPT1
:>:>> works fine).
:>:>>
:>:>
:>:>What about 10.02?
:>:>Dave
:>:>
:>
:>Same as 10.0 ( no exception)
:>
:>

Spoke too soon about fechg: even after fechg -d firefox the exception
still happens (still C0...05 in PM MERGE)

--
Barry Landy                        Email: Remove nospam in from address
192, Gilbert Road, Cambridge CB4 3PB









_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Allan-10
On Wed, 9 May 2012 19:55:18 UTC, Barry Landy <[hidden email]> wrote:

> On Wed, 9 May 2012, Barry Landy wrote:
>
> :>On Wed, 9 May 2012, Dave Yeo wrote:
> :>
> :>:>Barry Landy wrote:
> :>:>> On Tue, 8 May 2012, Barry Landy wrote:
> :>:>>
> :>:>> :>Both the preview and the releeas of 10.0.4
> :>:>> :>
> :>:>> :>printing to a CUPS USB connected printer works fine; printing to a LPT1
> :>:>> :>connected printer (HP5Llaserjet in case it matters) causes FF10 to end
> :>:>> with a
> :>:>> :>beep.
> :>:>> :>
> :>:>> :>
> :>:>>
> :>:>> extra points:
> :>:>> 1) it happens on two different computer with very different specs
> :>:>> 2) Firefox 10.0 does NOT show this effect (printing to the HPL5 via LPT1
> :>:>> works fine).
> :>:>>
> :>:>
> :>:>What about 10.02?
> :>:>Dave
> :>:>
> :>
> :>Same as 10.0 ( no exception)
> :>
> :>
>
> Spoke too soon about fechg: even after fechg -d firefox the exception
> still happens (still C0...05 in PM MERGE)

You need to reboot after such a change.


--
  Allan.

It is better to close your mouth, and look like a fool,
than to open it, and remove all doubt.
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Barry Landy
On Wed, 9 May 2012, Allan wrote:

:>On Wed, 9 May 2012 19:55:18 UTC, Barry Landy <[hidden email]> wrote:
:>
:>> On Wed, 9 May 2012, Barry Landy wrote:
:>>
:>> :>On Wed, 9 May 2012, Dave Yeo wrote:
:>> :>
:>> :>:>Barry Landy wrote:
:>> :>:>> On Tue, 8 May 2012, Barry Landy wrote:
:>> :>:>>
:>> :>:>> :>Both the preview and the releeas of 10.0.4
:>> :>:>> :>
:>> :>:>> :>printing to a CUPS USB connected printer works fine; printing to a LPT1
:>> :>:>> :>connected printer (HP5Llaserjet in case it matters) causes FF10 to end
:>> :>:>> with a
:>> :>:>> :>beep.
:>> :>:>> :>
:>> :>:>> :>
:>> :>:>>
:>> :>:>> extra points:
:>> :>:>> 1) it happens on two different computer with very different specs
:>> :>:>> 2) Firefox 10.0 does NOT show this effect (printing to the HPL5 via LPT1
:>> :>:>> works fine).
:>> :>:>>
:>> :>:>
:>> :>:>What about 10.02?
:>> :>:>Dave
:>> :>:>
:>> :>
:>> :>Same as 10.0 ( no exception)
:>> :>
:>> :>
:>>
:>> Spoke too soon about fechg: even after fechg -d firefox the exception
:>> still happens (still C0...05 in PM MERGE)
:>
:>You need to reboot after such a change.

Ah..... "documentation" does not say so. Implies it can be switched off
and on.

yes, after reboot the exception does not happen although printing is not
very happy (perhaps something wrong with the document?)

--
Barry Landy                        Email: Remove nospam in from address
192, Gilbert Road, Cambridge CB4 3PB









_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: 10.0.4 printting

Barry Landy
In reply to this post by Dave Yeo-3
On Wed, 9 May 2012, Dave Yeo wrote:

:>Barry Landy wrote:
:>> On Tue, 8 May 2012, Dave Yeo wrote:
:>>
:>> :>Barry Landy wrote:
:>> :>>  Both the preview and the releeas of 10.0.4
:>> :>>
:>> :>>  printing to a CUPS USB connected printer works fine; printing to a LPT1
:>> :>>  connected printer (HP5Llaserjet in case it matters) causes FF10 to end
:>> :>>  with a beep.
:>> :>>
:>> :>
:>> :>Can you look in your Firefox program directory and post the trp file to
:>> :>[hidden email]? preferably as a text attachment. As far as I know it
:>> :>shouldn't matter how the printer is connected but I'm not the expert.
:>> Perhaps
:>> :>Rich will become involved again and the trp file may help diagnose the
:>> problem
:>> :>or something will stand out in it.
:>> :>Dave
:>> :>
:>>
:>> I have attached the .trp file which indicates an C0000005 trap.
:>>
:>
:>Try disabling the Innotek Font engine.
:>Dave
:>

Contrary to my previous email I also get an exception printing to HPL5
from FF10.0 (still C05 but this time from a dfferent location; start of
.trp below)


______________________________________________________________________

 Exception Report - created 2012/02/22 12:29:24
______________________________________________________________________

 Firefox v10.0 - build 20120130135311

 OS2/eCS Version:  2.45
 # of Processors:  4
 Physical Memory:  511 mb
 Virt Addr Limit:  1536 mb
 Exceptq Version:  7.10 (Mar  1 2011)

______________________________________________________________________

 Exception C0000005 - Access Violation
______________________________________________________________________

 Process:  F:\FIREFOX\FIREFOX.EXE
 PID:      91 (145)
 TID:      01 (1)
 Priority: 200

 Filename: F:\FIREFOX\XUL.DLL
 Address:  005B:1D9FC56B (0001:012FC56B)
 Cause:    Attempted to read from 00000000
           (not a valid address)

______________________________________________________________________

 Failing Instruction
______________________________________________________________________

 1D9FC55B  MOV  ECX, [ESP+0x24]  (8b4c24 24)
 1D9FC55F  MOV  [ESP+0x18], ESI  (897424 18)
 1D9FC563  MOV  EBX, [ESP+0x2c]  (8b5c24 2c)
 1D9FC567  MOV  ESI, [ESP+0x28]  (8b7424 28)
 1D9FC56B >MOV  EDX, [EAX]       (8b10)
 1D9FC56D  MOV  [ESP+0x4], ECX   (894c24 04)
 1D9FC571  MOV  [ESP], EAX       (890424)
 1D9FC574  CALL [EDX+0x20]       (ff52 20)

--
Barry Landy                        Email: Remove nospam in from address
192, Gilbert Road, Cambridge CB4 3PB










_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
1234